博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
2014 ACM/ICPC Asia Regional Xi'an Online poj5007 Post Robot
阅读量:7043 次
发布时间:2019-06-28

本文共 2224 字,大约阅读时间需要 7 分钟。

Problem Description
DT is a big fan of digital products. He writes posts about technological products almost everyday in his blog.
But there is such few comments of his posts that he feels depressed all the day. As his best friend and an excellent programmer, DT asked you to help make his blog look more popular. He is so warm that you have no idea how to refuse. But you are unwilling to read all of his boring posts word by word. So you decided to write a script to comment below his posts automatically.
After observation, you found words “Apple” appear everywhere in his posts. After your counting, you concluded that “Apple”, “iPhone”, “iPod”, “iPad” are the most high-frequency words in his blog. Once one of these words were read by your smart script, it will make a comment “MAI MAI MAI!”, and go on reading the post.
In order to make it more funny, you, as a fan of Sony, also want to make some comments about Sony. So you want to add a new rule to the script: make a comment “SONY DAFA IS GOOD!” when “Sony” appears.
 
Input
A blog article described above, which contains only printable characters(whose ASCII code is between 32 and 127), CR(ASCII code 13, ‘\r’ in C/C++), LF(ASCII code 10, ‘\n’ in C/C++), please process input until EOF. Note all characters are
case sensitive.
The size of the article does not exceed 8KB.
 
Output
Output should contains comments generated by your script, one per line.
 
Sample Input
 
Apple bananaiPad lemon ApplepiSony 233 Tim cook is doubi from Apple iPhoneipad iPhone30 is so biiiiiiig Microsoft makes good App.
 
Sample Output
 
MAI MAI MAI! MAI MAI MAI! MAI MAI MAI! SONY DAFA IS GOOD! MAI MAI MAI! MAI MAI MAI! MAI MAI MAI!
 
#include <iostream>
#include<string>
#include  <stdio.h>
using namespace std;
int main()
{
string a ;
while(getline(cin,a))
{int n=a.length();
int i;
for(i=0;i<n;i++)
{
    if(a[i]=='A')
{if(a.substr(i, 5)=="Apple")
    cout<<"MAI MAI MAI!"<<endl;}
else if(a[i]=='S')
{if(a.substr(i, 4)=="Sony")
    cout<<"SONY DAFA IS GOOD!"<<endl;}
else if(a[i]=='i')
{bool p1=0;
    {if(a.substr(i, 6)=="iPhone")p1=1;
        if(a.substr(i, 4)=="iPod")p1=1;
        if(a.substr(i, 4)=="iPad")p1=1;}
        if(p1==1)cout<<"MAI MAI MAI!"<<endl;
    }
}
}
return 0;
}

转载于:https://www.cnblogs.com/lengxia/p/4387793.html

你可能感兴趣的文章
hanlp提取文本关键词的使用方法记录
查看>>
SpringBoot - 日志配置
查看>>
Python零基础学习笔记(十四)—— while语句
查看>>
swap释放过程浅析
查看>>
linux gzip
查看>>
Python知识点:lambda, map, filter
查看>>
zabbix snmp模板通用
查看>>
RSA 2019安全大会:企业资产管理成行业新风向标,云上安全占绝对优势
查看>>
Angular prod打包编译异常
查看>>
RPG游戏开发基础教程
查看>>
起落落落之后,区块链商用化的春天在哪儿?
查看>>
教你用C语言编写万年历,程序员超乎你的想象!
查看>>
WPF开发-Label自定义背景-Decorator
查看>>
抓住热门话题一对一直播,如何在风浪四起的直播市场劈风斩浪?
查看>>
[Phoenix] 十一、查询计划详解
查看>>
运行时数据区——Java堆
查看>>
JAVA springboot ssm b2b2c多用户商城系统源码:服务消费(Feign)
查看>>
OkHttp网络连接封装工具类
查看>>
基于Spark的机器学习实践 (二) - 初识MLlib
查看>>
HBase高效一键迁移的设计与实践
查看>>